Avalehe pilt
Technical requirements for mobile-ID
05/23/2017

Web browsers and ID card software that are compatible with mobile-ID:

In Windows environment:

  • Windows XP 32bit
  • Windows Vista 32bit and 64bit
  • Windows 7 SP1 32bit and 64bit
  • Windows 8 32bit and 64bit
  • Windows 8.1 32biand 64bit
  • Windows 10 32bit and 64bit

 

In MacOS X environment:

  • Mac OS X 10.8, 10.9, 10.10 (Intel)

 

In Linux environment:

  • Ubunutu 12.04LTS, 13.10, 14.04LTS, 14.10


As for web browsers, the most recent browser versions, supported by operational systems,  are being supported:

  • Windows: Internet Explorer, Mozilla Firefox, Google Chrome
  • Mac OSX: Mozilla Firefox, Safari, Google Chrome
  • Linux: Mozilla Firefox, Google Chrome


The ID-card software can be downloaded from: http://installer.id.ee

NB! If the PIN-codes of the digi-ID of an e-resident are lost, then the document shall be useless and, upon necessity, a new digi-ID of an e-resident shall be applied for.

For opening the mobile-ID application in PDF format please use the Adobe Reader software. The software can be downloaded from: http://get.adobe.com/reader/

Overall information about mobile-ID
Conditions for use of certificates mobile-ID (in Estonian)
Useful information about mobile-ID